Saving scripts

    To save a script:
    1 Open the File menu and choose Save or Save As.
    2 Choose how you want to save the script using the Format menu:
    • as a compiled script, which you run only in the Script Editor
    • as a classic application
    • as a Mac OS X application
    • as a text file, which you can open in other applications
    3 If you are saving the script as an application, select options for the application.
    4 Name the script, select where to save it, and click Save.

    You can also save a script as a run-only script. If you save a script as a run-only script, other users cannot open the script in the Script Editor.

    To save a script as a run-only script:
    • Open the File menu and choose Save As Run-Only.

Saving scripts as applications

    When you save a script as an application, sometimes called an "applet," you have several choices for how you save it.

    Choosing a type of application:
    You can save a script as a classic application or a Mac OS X application:
    • As a classic application, your script will run on any system that supports AppleScript.
    • As a Mac OS X application, your script will run only on computers with CarbonLib installed, including Mac OS X.

    Saving a droplet application:
    To run a script saved as an application, you double-click it. If the script has an On Open handler in it, then you can run the application by dropping a file or folder on it. Such an application is sometimes called a "droplet."

    Selecting options:
    When you save a script as an application, you can select either of these options:
    • Stay Open
    Select this option to keep the script open after it runs. Do this if you want to send commands to the open script from another script.
    • Never Show Startup Screen
    Select this option when you don't want to display the startup screen (which displays the Description field of the script).

 


Table of contents