Toast 5 Titanium feature. Toast Lite users learn more about upgrading to Toast 5 Titanium.

Tips for Working with ISO 9660

    These tips explain some of the options available with ISO 9660 format.

Features of the Select ISO 9660 Window

    The Select ISO 9660 window has panels you access by clicking the tab you want: Files, Layout, or Settings. Before you record the CD, you can make changes that affect the final contents of the CD.

    • Files: Selecting the data
    • Layout: Determining the layout or order of the files on the CD
    • Settings: Setting the options for file naming, format, etc.

Files

    The data window lists the files and folders you have selected for inclusion on your CD. Changes that you make in this window change the contents of the CD.

    All directories are displayed in alphabetical order. The list behaves very much like a list view sorted by name in the Finder.

    To open a CD or folder and display its contents, click the arrow to the left of its name. (The arrow points down.) To close the item, click the arrow again.

    To open all folders at once, press the Option key while you click an arrow. To close all folders, repeat the procedure.

Creating a New CD or a New Folder

    If the Selection window is empty, you can create a new CD by clicking the New CD button. An untitled CD icon appears in the list. You can then add other items to the CD by dragging and dropping, or by using the Add button.

    If the Select ISO 9660 window already contains some items, the name of the button changes from New CD to New Folder. To create a new, empty folder at the same level as any selected item, click New Folder. If nothing is selected when you click New Folder, the new folder is placed at the root level.

Importing Data

    Use one of the methods described below:

    • Drag & Drop Method
    • Selection Method

    In the Select ISO 9660 window, click the Add button. Then, in the dialog box that appears, select the item you want and click Choose.

    Repeat the sequence for all the items you want to add, and click Done when youÕre finished.

Changing Names and Visibility

    You can change the names of files, folders, and CDs, and make them visible or invisible. None of these changes affects the original items on your hard disk.

    To change the name or visibility of an item in the list, double-click it.

    When Invisible is checked, the CD-Recorder writes the item to the CD, but it wonÕt be visible in the Finder.

    Invisible items are displayed in gray in the list:

    1 In the Information window that appears, type a new name.
    2 To make the item invisible, click the Invisible check box.
    3 When you're finished, click OK.

Copying the Contents as Text

    To copy the contents of the list, choose Copy from the Edit menu.

    These are the possible options to choose from:

    • All items: All items in the files window are copied as text.
    • Renamed items: Only items Toast has renamed are copied as text. For your convenience, Toast automatically assigns new (legal) names that are compatible with the naming convention you choose in the Settings panel.
    • Items with illegal names: Only items with illegal names are copied as text. These names violate the Joliet naming convention, using illegal characters such as the slash (/).

    You can paste the copied text into any other application. With the path information from the list, you can track down and edit names as needed.

Changing the Hierarchy

    You can reorganize the hierarchy of the CD by dragging items in the list. You can move files to different folders or move folders until you have the layout you want.

Resolving Aliases

    If the data you select for your CD contains aliases, you can determine how those aliases are treated when the CD is written. In the ISO 9660 data window with the Files panel active, you can see the Resolve Aliases check box in the lower right corner of the panel.

    • Checked: Toast writes the original files onto your CD.
    • Unchecked: Toast writes the aliases to the CD.

Layout

    If you donÕt change the Layout portion of the Files Selection window, then the files are written in the following order:

    To leave the most space possible for additional sessions, Toast writes files defragmented.

    In most cases the standard layout is adequate. However, for special purposes, you can change the order in which the files are written on the CD.

    • Select the file or files you want to move, and then click Move to top or Move to bottom, as appropriate. Or you can drag files to the position you want.
    • Toast writes files located at the top of the list first (towards the inner part of the CD).

Settings

    Choose the format you want for your ISO CD from the Format pop-up menu:

    • CD-ROM: For single-session CDs and CDs to be duplicated by a replication plant, choose CD-ROM. Some older CD-ROM drives can only read CDs in this format.
    • CD-ROM XA: For multisession CDs, CD-ROM XA format leaves you the possibility of adding sessions later.

Naming

    The Naming menu lets you specify how you want Toast to handle file names that are not compatible with the ISO file format.

    Toast automatically transforms file or folder names so they conform to the naming option you choose. The Files panel lists the transformed name, along with the original name (in gray).

    Name requirements:

    • ISO 9660 Level 1ÑThis is the original ISO naming format and is considered restrictive (most systems donÕt need pure ISO standard).
    • Length: 8.3 characters
    • Characters: uppercase letters A-Z, numbers 0-9 and the underscore _. No other characters are allowed.
    • Examples: ISO_NAME.TXT, IMAGE_1.TIF

    ISO Level 1 has a limitation of 8 levels of nested directories. Toast allows you to have more than 8 levels, but the data might not be readable on many systems. (Toast warns you before trying to write an ISO CD with more than 8 levels.)

    Name requirements:

    • Allow MS-DOS Names: similar to ISO Level 1 but not as restrictive. Use this option for CDs intended for DOS or Windows 3.x systems.
    • Length: 8.3 characters
    • Characters: uppercase letters A-Z, numbers 0-9, the underscore _, and these special characters: { } @ - ^ ! $ % & ( ) ` « # ~

    a Choose Disc Image from the Format menu. The disc image you saved in step 8a should appear in the Disc Image window. If it doesnÕt, click Select, and open the disc image from the dialog box that appears.
    b Click the Record button.
    c In the Record dialog box, click Write Disc.
    d When you see the message, "Verification completed successfully," click Eject.

    ISO format has a limitation of 8 levels of nested directories. Toast allows you to have more than 8 levels but the data might not be readable on many systems (you will be warned before trying to write an ISO CD with more than 8 levels).

    • Allow Macintosh Names: causes Toast to leave all file and folder names as they are. If you are using ISO format CDs to make incremental backups from your Macintosh, choose this option.
    • Joliet (MS-DOS + Windows): preserves long file names on the CD for use under Windows 95 or later and Windows NT ¨ , while also being fully compatible with older versions of DOS and Windows.

    A Joliet format CD contains two file systems: An ISO 9660 compliant file system using MS-DOS names, and the Joliet file system using long Unicode names. Both file systems point to the same data files. Remember that only Windows 95, 98, 2000 ME, and Windows NT 4.0 systems will have access to the long names. ISO 9660-compliant systems such as MS-DOS, UNIX, or Mac OS will only see the ISO 9660 file system. A cross-platform ISO 9660 CD created with Joliet names actually contains three different file systems: Mac OS (Standard or Extended), ISO 9660, and Joliet.

    Name requirements:

    • Allow Macintosh Names: causes Toast to leave all file and folder names as they are. If you are using ISO format CDs to make incremental backups from your Macintosh, choose this option.
    • Length: 31 characters
    • Characters: These characters are not allowed */:;?\
    • Example: 1998 Report to Shareholders

    When you select Joliet in ISO 9660 format, Toast does not automatically change file names. Instead, illegal names (containing */:;?\ ) are flagged with three red exclamation marks in the file list.

    When creating Joliet names in Custom Hybrid format, Toast automatically replaces illegal characters.

    To export a list of illegal names to the clipboard, choose Copy from the Edit menu and click Items with illegal names.

    Viewing the short names under Joliet

    This has no effect when the CD is read on a PC.

    For hybrid CDs this option is not needed, as both forks are always written to the HFS/HFS+ part of the CD.

    • To view the short names seen by MS-DOS or (if you're not creating a hybrid CD) Macintosh systems, click the Settings tab. In the Settings panel, choose Allow MS-DOS Names from the Naming pop-up menu.
    • If you change a short name, the long (Joliet) name will be changed too.
    • Append Version Numbers (;1): This option adds the standard ISO version number (;1) to every file name. This version number is normally invisible, and is seldom needed. This option is not available with Macintosh names.
    • Use Apple Extensions: To have Toast write both the data and resource forks for Mac files, check this option.
    • Set Defaults: To preserve your current settings as the default for future Toast sessions, click this button.
    • More: To enter a variety of additional information that will be written to the CD as part of the directory, click More. In most cases, this information is not visible or accessible to the user.

Concerning Rockridge Extensions for UNIX

    Toast cannot create CDs with the Rockridge extensions for UNIX. It can, however, write images created by the UNIX utility "mkisofs" which do incorporate Rockridge name extensions.

    Toast automatically transforms file or folder names so they conform to the naming option you choose. The Files panel lists the transformed name, along with the original name (in gray).

The Appearance of Windows on the CD

    On a Macintosh, all windows of an ISO CD will be sorted by icon.

Multisession FormatÑImporting a Session from a CD

    You can import a session to add to a CD that already contains at least one additional ISO session.

    For the ultimate in control, Toast lets you import the directory of previous ISO sessions and then edit and make any changes you want. You can delete, rename, move, and reorganize any of the files and folders of the old sessions.

    To import an existing session

    If there is at least one ISO session already written on the CD, the Import Session dialog box appears:

    1 Make sure the CD is in your CD-Recorder.
    2 Click the arrow that appears on the lower right side of the Files panel of the ISO 9660 window. You can see it above the Done button.
    3 Choose Import Session from the pop-up menu.
    4 Select the session you want to import (usually the most recent session).
    5 To specify how you want the session to appear in the new sessionÕs directory, click one of the radio buttons.
    • Merged: The name of the old session becomes the name of the new session, and the data of the old session becomes the data for the new session.
    • Put into a directory: The old session is put in a directory with its name. If you havenÕt selected data before importing the session, a new CD directory is created containing one folder which contains the data from the old session.
    6 Click OK.

Modifying an Existing File Structure

    At this point you can make these changes to the structure:

    • Move files and folders to another position.
    • Add or remove files and folders.
    • Rename files, folders, and the CD.
    • Change the visibility of files and folders.
    • Add new data to any part of the directory structure.

    The way you arrange the data determines the layout of the CD once you write the new session.

Removing an Imported Session

    To remove an imported session from the ISO directory window, choose Remove Imported Session from the pop-up menu in the lower right corner of the window. All the files and folders from the imported session are removed from the window, leaving only new data that you may have added.

 


Table of contents